CEP eclipse plugin fails to install on eclipse 3.5. Why? - Complex Event Processing

Hello,
I tried to install the CEP plugin that is packaged with the ofm_ocep_windows_11.1.1.1.0_32 installation. It complains about missing dependencies (see below). Does anyone know where to get the missing stuff, pls?
I have tried using two eclipse installations as base, and then tried to add the CEP plugin:
1) eclipse 3.5 (galileo) downloaded from eclipse.org + OEPE plugin (for galileo) downloaded from OTN
2) ofm_ocep_windows_11.1.1.1.0_32.zip from OTN
Both installations complain about missing dependencies.
Cannot complete the install because one or more required items could not be found.
  Software being installed: Oracle CEP Tools 11.1.0.20090622-1517 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.0.20090622-1517)
  Missing requirement: Oracle CEP Tools 11.1.0.20090622-1517 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.0.20090622-1517)
  requires 'org.eclipse.jdt.feature.group [3.3.1,3.4.0)' but it could not be foundThanks in advance,
H 

The official doc says it needs Eclipse 3.3.2 and WTP 2.0.2, see
http://www.oracle.com/technology/products/event-driven-architecture/cep-ide/11/index.html. 

We are hoping to support Eclipse 3.5 in the near future, but having people ask for it helps build the case for incurring the effort to QA it and ship it, so thanks for asking! 

Has this been resolved yet? I'd like to vote for this as well. 

serff wrote:
Has this been resolved yet? I'd like to vote for this as well.We don't have a public fix for this as yet. Note that this is not so much a fix as a new plugin, so the decision to support 3.5 is not a simple one. 

The Eclipse Galilio 3.5 update from the website works now.
Go to Eclipse Help and Click and Find and Install Software-> Enter the below URL.
http://download.oracle.com/technology/software/cep-ide/11/
You will be prompted with options to update the Eclipse 3.3 or Eclipse 3.5 and select the 3.5 updates to complete the installation
-Vijay Polsani
Edited by: vijay polsani on Nov 12, 2009 1:01 PM 

Vijay,
I have followed the instructions and using the archive file (zip), I am getting the following error -
"cannot complete the install because one or more required items could not be found
software being installed Oracle CEP Tools 11.1.1.20091022.1701 (com.bea.wlevs.eclipse.tools.feature.featuregroup. 11.1.1.20091022.1701)
Missing Requirement -Oracle CEP tools 11.1.1.20091022.1701
(com.bea.wlevs.eclipse.feature.feature.Group 11.1.1.20091022.1701 requires 'org.eclipse.emf.feature.group(2.5.0, 2.6.0)'but could not be found
My env -
OEL 5.x on 64-bit + Eclipse 3.5.0) and using the link - above
Thanks
- 

Are you sure you followed the instructions at:
http://download.oracle.com/technology/software/cep-ide/11/11.1.1/systemreqs.html
and installed the Eclipse IDE for Java EE Developers using this link:
http://download.eclipse.org/technology/epp/downloads/release/galileo/SR1/eclipse-jee-galileo-SR1-win32.zip
My suspicion is you are trying to install the OCEP plugins into a vanilla version of Eclipse, but OCEP actually requires WTP (the Web Tools Project Platform) to be there as well. WTP comes with the JEE Eclipse package. WTP also requires EMF, which is where the complaint your seeing is coming from.

Related

Oracle CEP IDE tools installation

Hi,
I am unable to install Oracle CEP IDE tools for eclipse with the following link (Oracle CEP Tools Update - http://download.oracle.com/technology/software/cep-ide/11/) which is specified in section 3.2.4 on http://docs.oracle.com/cd/E17904_01/doc.1111/e14301/ide_intro.htm.
I am getting the following error:
Cannot complete the install because one or more required items could not be found.
Software being installed: Oracle CEP Tools 11.1.1.20111115-1500 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.1.20111115-1500)
Missing requirement: Oracle CEP Tools 11.1.1.20111115-1500 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.1.20111115-1500) requires 'org.eclipse.jdt.feature.group [3.6.0,3.7.0)' but it could not be found
The eclipse IDE I am using is http://www.oracle.com/technetwork/middleware/complex-event-processing/downloads/index.html?ssSourceSiteId=ocomen
Please resolve this.
Regards,
Swati 
Hi Swati,
Please provide the OEP version and Eclipse version you are using.
For PS6, we use the Eclipse indigo/SR2/ JEE version. You can download it at http://mirrors.xmission.com/eclipse/technology/epp/downloads/release/indigo/SR2/
Thanks
Junger 
I'm experiencing same issue. Installed OEP is version 11.1.1.7.
Eclipse version is:
Eclipse Java EE IDE for Web Developers.
Version: Indigo Service Release 2
Build id: 20120216-1857
And the worst part is that I have the Eclipse JDT installed:
version: 3.7.2.v20120120-1
ID = org.eclipse.jdt.feature.group
Specific error I get is:
Cannot complete the install because one or more required items could not be found.
Software being installed: Oracle CEP Tools 11.1.1.20111115-1500 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.1.20111115-1500)
Missing requirement: Oracle CEP Tools 11.1.1.20111115-1500 (com.bea.wlevs.eclipse.tools.feature.feature.group 11.1.1.20111115-1500) requires 'org.eclipse.jdt.feature.group [3.6.0,3.7.0)' but it could not be found
Is it potentially because the OEP plug-in can't recognize version 3.7.2 of the JDT? I'm looking for prior versions now to test this theory...can't identify the archive site yet...
UPDATE: no joy yet. I'm starting to wonder if the OEP Eclipse plug-in actually works on 64 bit Linux. I noticed on the download site that Oracle points you to the 32 bit Eclipse download, even though I've selected 64 bit Linux. 32 bit Eclipse doesn't make sense for a 64 bit OS...underlying packages won't be there and in fact Eclipse won't launch as a result.
Edited by: Eyeballs on Apr 22, 2013 9:52 PM 
Finally figured it out...not what I expected. I kept the 64 bit Linux, Java and Eclipse versions. What I did differently was not to use the download.oracle.com site to install the OEP plugin. The download site only has up to version 3.6 of the plug-in, however, version 3.7 of the plug-in is copied to your system when you install OEP. When you select to Install New Software, add your site, but select the local box on the right.
Then browse to this folder:
Oracle/Middleware/ocep_11.1/eclipse-update-site/cep-tools=11.1.1.20130109-2314/
When you do this, you'll see version 3.7 of the OEP plugin is discovered and it'll install successfully.
Kudo's to this blog for guiding me to the answer:
http://techrambler99.blogspot.com/2012/09/installing-oracle-complex-event.html 
Thanks, Eyeball. This is what we need to do. And this is documented properly in the Developer Guide. 
Hey Junger,
Which Developer's Guide are you looking at? I'm looking at version 11.1.1.7 and it says nothing about using the plug-in packaged with the local install. It directs you to the download.oracle.com site via the Install New Software option:
http://docs.oracle.com/cd/E28280_01/dev.1111/e14301/ide_intro.htm#CHDGBGGA
If there's a newer one, please let me know, just using what I found on our Documentation page at Oracle.com.
Thanks,
Clayton 
Have you tried updating the Eclipse Helios Installation with the following remote update url for CEP:
http://download.oracle.com/technology/software/cep-ide/11/
Thanks,
Wajid 
Excellent! This worked perfectly. Thanks for sharing the solution.

Dependency error when installing OEPE on Eclipse Ganymede

Hello,
I am using an Eclipse Ganymede J2EE with all the current updates applied.
The version number eclipse is showing is
Version: 3.4.2
Build id: M20090211-1700
When I try to install OEPE from the ganymede update site, I get the following error:
"Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements org.eclipse.ui [3.4.2.M20090204-0800]."
How can I install OEPE?
With kind regards
Florian Reiser 
Hello,
Have you tried this again? It could have been a network connectivity issue.
Also do you have a fresh install of Eclipse or are there other plugins in the install where you tried to install OEPE? 
Hello,
yes I have tried it again. It still fails.
No it is not a fresh install of eclipse, but has jformdesigner, tptp, the properties editor and other plugins installed.
But I don't think that this should influence the installation. It requires an older version of the eclipse.ui module as is installed. 
Hello,
I could narrow the error in. The message appears when I want to select one of the following modules:
- Oracle Database Tools
- Oracle Enterprise Pack for Eclipse
The following modules could be installed without error:
- Oracle Common Tools
- JSF Facelets Tools Incubator
What can I do to get it working? 
Hello Florian,
I have tried the update with a fresh Ganymede SR2(3.4.2) install and did not notice any issues. I wonder if there is a conflict between the plugins you currently have installed and OEPE 1.1
could you list the additional plugin versions you have installed along with the list of update site which are checked, I will try replicate locally.
could you also try downlaoding the product plugin zip from http://www.oracle.com/technology/software/products/oepe/oepe_11g.html and extracting the contents to the dropins folder in your eclipse installation ?
thanks
Raj

OEPE update install error

I can not update my OEPE install to version 1.1.0.200903091141 via the update site. I am getting the following error.
Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.0.v3448f].
I have checked my plugins folder and the Jar org.eclipse.swt_3.4.2.v3452b.jar is present however this looks like it is newer that the required version from above. However the version of the Jar that is installed would appear to match Eclipse 3.4.2. Does anyone know a solution to this?
Regards
Neil 
Hi Neil,
How did you install Ganymede SR2 build? Did you upgrade from an earlier version via update site or is it from a all-in-one zip file?
Are you trying to upgrade from OEPE 1.0 to 1.1?
Thanks,
Ram 
Ganymede was SR2 (3.4.2) was downloaded and installed as a clean install. OEPE 1.0 has been installed and I am trying to upgrade to 1.1.
The full error report is as follows:
Cannot complete the request. See the details.
Oracle Common Tools is already installed, so an update will be performed instead.
Oracle Database Tools is already installed, so an update will be performed instead.
Oracle Enterprise Pack for Eclipse is already installed, so an update will be performed instead.
Oracle WebLogic Server Tools is already installed, so an update will be performed instead.
Spring IDE Core (required) will be ignored because a newer version is already installed.
Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.0.v3448f].
Regards
Neil 
I started again from a clean Eclipse install. I installed OEPE 1.1 first and it installed / ran fine. Now when I try to upgrade the Spring IDE (2.2.3.RELEASE) I get the error as before. The full error details follow:
Cannot complete the request. See the details.
Spring IDE Core (required) is already installed, so an update will be performed instead.
Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.0.v3448f].
Can OEPE work with an updated version of the Spring IDE? The old version of OEPE (1.0) ran with Spring IDE 2.2.3.RELEASE
Regards
Neil 
Hi Neil,
The Spring update is a known issue and a bug has been logged. You can try the following workaround if you prefer working with Spring IDE v2.2.3
- Install Ganymede SR2 (3.4.2)
- Install OEPE via update site http://download.oracle.com/otn_software/oepe/ganymede
NOTE: Make sure to de-select "Oracle Enterprise pack for Eclipse"
- After completing OEPE installation update Spring IDE
FYI: Oracle Enterprise Pack for Eclipse is a root feature and doesn't actually have any functionality. It is just an aggregator of other features that have functionality. The only thing you would loose is to update any new OEPE feature (released in future).
Yes, OEPE v1.1 works fine with the updated Spring IDE (v2.2.3).
Thanks,
Ram 
Ram,
Thanks for the reply. I will give this a shot the next time I need to re-install Eclipse. I have already installed "Oracle Enterprise pack for Eclipse" and I do not have time to re-build the environment at the moment. Spring IDE 2.2.0 will do for the time being ;-)
Regards
Neil

Can't Upgrade to OEPE 11.1.1.7 on Eclipse Helios (Windows 7)

I keep getting the following error trying to upgrade via Update Site http://download.oracle.com/otn_software/oepe/helios:
Missing requirement: Oracle Eclipse Patch 120376 1.6.0.201007221419 (oracle.eclipse.tools.helios.patch.120376.feature.group 1.6.0.201007221419) requires 'org.eclipse.wst.common.fproj.feature.group [3.2.0.v201005290030-377A78s73533D5L355B]' but it could not be found
Cannot satisfy dependency:
From: Oracle Eclipse Patch 120376 Source 1.6.0.201007221419 (oracle.eclipse.tools.helios.patch.120376.source.feature.group 1.6.0.201007221419)
To: oracle.eclipse.tools.helios.patch.120376.feature.group [1.6.0.201007221419]
Where should I get this missing component? 
The patch mentioned will be applied only to Helios GA, which is an appropriate version for OEPE 11.1.1.7. The missing feature is part of WTP (Web Tools Platform). "Eclipse Helios" can be used to describe multiple "packages", or Eclipse distributions. You need "Eclipse IDE for Java EE Developers" to run OEPE, since OEPE depends on WTP. Or you need to add WTP to a different "package", if that's more appropriate for you. If you are sure that you do have WTP Helios, then I'm not sure at this point what would cause this condition.
- Ian 
Not sure which version of Helios I have installed. Here is what "About Eclipse" says:
Version: Helios Release
Build id: 20100617-1415
I already have WTP 3.2.1 and OEPE 11.1.1.6 running. However, trying to upgrade or install anything throws that error. Any idea what I should do? Should I try to uninstall WTP and install it again?
Thank you. 
OEPE 11.1.1.7 runs on Helios GA (WTP 3.2.0) and Helios SR1 (WTP 3.2.2). The update site will not work for your situation (WTP 3.2.1). You can find an all-in-one OEPE installer at http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html, and you can find other installation options at http://download.oracle.com/docs/cd/E15315_07/help/oracle.eclipse.tools.common.doc/html/install.html.
- Ian 
Thank you, Ian. If I run the all-in-one installer, will it preserve all my current OEPE configuration and settings? I have a bunch of connections saved and wouldn't want to loose them. 
Myself, I would install into a new "Middleware Home", so as not to impact your current environment. Then I would make a backup of some form of my current workspace (maybe copy or zip the entire workspace folder). When you open your workspace with the new OEPE installation, I would expect that all configuration and settings that could possibly be maintained across versions would be. But on this point I am not sure, which is why I strongly recommend a workspace backup first.
Sometimes I copy a workspace and work in the new one, maintaining the old one in case I need to fire up an old version of my workbench and view the old workspace. Usually, only after an old workspace has been idle for some time and I have no good reason to keep it around, I delete it. Better safe than sorry, right?
I'm hoping someone else will speak up and give a better idea of what to reasonably expect when you open an 11.1.1.6 workspace in 11.1.1.7; it's not something I have had cause to do and so I am not sure exactly what to expect.
- Ian 
I wouldn't worry about compatibility of 11.1.1.6 workspace when opened with 11.1.1.7. Such cases are well tested. All of your settings are kept in the workspace, so switching from one OEPE/Eclipse install to another will not cause you to loose your settings.
- Konstantin 
Me too not able to install the weblogic plugin, when i enter the url http://www.oracle.com/technetwork/developer-tools/eclipse/downloads/index.html into eclipse, it prompts me for login details, even after entering valid credentils, i get authentication failed error.
It is fristrating with Oracle, BEA was much better 
The URL you entered is not a valid Eclipse Update Site URL. The OEPE Update Site URL for Eclipse 3.6 Helios is
http://download.oracle.com/otn_software/oepe/helios
Please see the Installation Instructions if you need more information - http://download.oracle.com/docs/cd/E15315_07/help/oracle.eclipse.tools.common.doc/html/install.html#update_manager
-Greg 
Thank you. Should I maybe try to upgrade my WTP 3.2.1 to 3.2.2 first and then use the Eclipse update URL? I really want to upgrade the OEPE plug-in/dependencies only and leave everything else as is, if possible. 
Tried to upgrade WTP to the latest 3.2.3, but received the following error (see below). Any idea where I can get the missing org.eclipse.wst.sse.core? Thank you.
Cannot complete the install because one or more required items could not be found.
Software currently installed: Oracle Eclipse Patch 317638 Source 1.6.0.201007221419 (oracle.eclipse.tools.helios.patch.317638.source.feature.group 1.6.0.201007221419)
Missing requirement: Oracle Eclipse Patch 317638 1.6.0.201007221419 (oracle.eclipse.tools.helios.patch.317638.feature.group 1.6.0.201007221419) requires 'org.eclipse.wst.sse.core [1.1.500.v201006020308-p001]' but it could not be found
Cannot satisfy dependency:
From: Oracle Eclipse Patch 317638 Source 1.6.0.201007221419 (oracle.eclipse.tools.helios.patch.317638.source.feature.group 1.6.0.201007221419)
To: oracle.eclipse.tools.helios.patch.317638.feature.group [1.6.0.201007221419] 
Just checked Help -> Already Installed -> Configurations and it looks like I've already have this installed:
org.eclipse.wst.sse.core (1.1.501.v201007131444) "Structured Source Model" [Active]
Not sure why WTP upgrade is complaining then. 
As previously stated, OEPE 11.1.1.7 runs on Helios GA (WTP 3.2.0) and Helios SR1 (WTP 3.2.2). It doesn't run on WTP 3.2.1 and it doesn't run on Helios SR2 (WTP 3.2.3).
OEPE 11.1.1.7.1 will support Helios SR2 (WTP 3.2.3).
If you're running WTP 3.2.1, the update site is not going to work for you, as you have discovered (because it will update WTP to 3.2.3, at which point you have an incompatible WTP version for OEPE 11.1.1.7).
- Ian 
It is complaining because it couldn't satisfy OEPE dependencies when you attempted to move to WTP 3.2.3 release.
Neither OEPE 11.1.1.6 nor 11.1.1.7 support WTP 3.2.3 release. There is a 11.1.1.7.1 release in the works that will have that support, but it will not be out for a few more weeks. Updating to WTP 3.2.2 will be difficult as eclipse.org update sites always point to the latest. Even if you do find an update site with WTP 3.2.2 release, you will need to update to WTP 3.2.2 concurrently with updating to OEPE 1.7.0 as OEPE 1.6.0 does not support WTP 3.2.2.
You can wait for OEPE 11.1.1.7 release and then perform Help -> Check for Updates action to simultaneously upgrade your WTP and OEPE plugins. If you need to move to OEPE 11.1.1.7 sooner, the easiest way is to download the all-in-one kit of that release.
- Konstantin 
Thank you for the detail explanation, Konstantin. I will wait for the OEPE 11.1.1.7 with WTP 3.2.3 support.

oepe juno 4.3 support

When is there going to be an all-in-one-bunde for eclipse 4.3?
I tried to add oepe plugin to eclipse 4.3 sdk and it gave me a strange error and would not let me install oepe plugin.
Edited by: SamuelMager on Dec 8, 2012 9:06 AM 
Do you mean Eclipse 4.2? Eclipse 4.3 is part of the Kepler release for June of 2013 and there is no OEPE support for that version yet.
Eclipse 4.2 is a less stable platform than Eclipse 3.8, which has all of the same features. There are no plans to produce OEPE distros with Eclipse 4.2, but the combination is supported and tested by Oracle. For best results, start with Eclipse IDE for Java EE Developers distro that you can find on the eclipse.org download site. Installing OEPE into a different distroy can be more difficult due to unsatisfied dependencies.
- Konstantin 
We will start producing OEPE builds on Eclipse Kepler Milestone releases next year (in the past it has been around the March/April time frame) but whether this will be on Eclipse 3.x or 4.x is still being evaluated.
Thanks,
Greg 
First I download eclipse-jee-kepler-M3-win32.
Second I tried to install via update
http://download.oracle.com/otn_software/oepe/juno
NOTE: There is no http://download.oracle.com/otn_software/oepe/kepler
When tried to install OEPE JUNO via update I got this dependency error:
Cannot complete the install because one or more required items could not be found.
Software being installed: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
Missing requirement: Oracle WebLogic Web Services Tools UI 5.2.0.201211211917 (oracle.eclipse.tools.webservices.ui 5.2.0.201211211917) requires 'bundle org.eclipse.jdt.ui [3.8.0,3.9.0)' but it could not be found
Cannot satisfy dependency:
From: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
To: oracle.eclipse.tools.webservices.ui [5.2.0.201211211917]
I have real development to do at work.
I am switching back to Eclipse Juno OEPE all-in-one-bundle.
I don't have time to figure out how to make Eclipse Kepler work with OEPE plugin.
I like the new UI I see in Kepler. And I am excited to use Kepler once the OEPE plugin can work with Kepler.
We use WebLogic and I need to use the OEPE so I can start and stop WebLogic.
I hope you make OEPE available on the 4.3 branch since that seems to be the one with the new UI.
Edited by: SamuelMager on Dec 11, 2012 1:46 PM 
Hi,
Yes, please continue to use OEPE with Eclipse Juno as we have not started supporting Eclipse Kepler yet.
Thanks,
Greg 
The question is answered.
I really can use OEPE for Kepler 
Thank... http://gclubtgonline.exteen.com/http://royal1688-online.blogspot.com/http://goldclub-slot.blogspot.com/http://gclubtgonline.exteen.com/

Categories

Resources