AXIS version - aqualogic.bpm.modeling(Archived)

We are working with WebSphere Application Server and ALBPM 5.5 SP10. We have some questions:<br><br>
- We need to know what version of AXIS is running in ALBPM 5.5 SP10, and if it is possible to update with a new version (e.g.,AXIS 2.0).<br><br>
- We need to know the deployment process details of ALBPM 5.5 SP10 with AXIS.<br><br>

Fuego 5.5 uses a beta of Axis 1.1, ALBPM 5.7 uses Axis 1.2.
We need that version since we have code that is version dependent, it is not possible to use AXIS 2.0.
The way you should configure WAS is to create a library that would include fuegoj2ee-lib-all.jar and choose "parent first" as the classloader policy.
That way Fuego would still use Axis 1.1 and your other apps would run in another version. 

When ALBPM 5.7 will be disponible? 

we are close to GA now, the scheduled release date is around October. 

Would be possible to use Axis 1.4 in ALBPM 5.7?<br><br>
(Axis 1.2 has a lot of bugs)<br><br>
If it is possible, how can we do it? 

ALBPM 5.7 cannot change the Axis version it is using internally.
On the other hand, we should be able to interoperate with any other SOAP implementation, including other versions of Axis.
MAriano Benitez
AquaLogic BPM 5.7 SP1 is now available!


Upgrading java version from 1.4 to 1.5; problem in Collab or Content?

Anyone know any issues with the Portal, Collab, or Publisher servers if you upgrade from java 1.4 to 1.5? We are running .NET 5.0.4 on IIS for the Portal, Publisher 6.0, and Collab 4.0.2. Collab and Content are running on WebLogic 8.1 SP3 and Sun JVM Version 1.4.2_11-b06. Our sys admins and network people are pushing us to upgrade to java version 1.5 from the 1.4 version. Anyone know of or have seen any adverse system reactions to this kind of upgrade on the Portal, Publisher, or Collab servers? 
First that come in my mind that all this application use IDK (at least), and IDK (up to 5.3) required Java 1.4. As I know last IDK version (5.4) works in 1.5 (at least has to).
So if you want to write portlets in 1.5 you have to use IDK 5.4.
But I am pretty sure that for these applications just updating libraries shipped with IDK 5.4 will not be enough.
Edited by Bryazgin at 05/14/2007 2:15 PM

WSRP: Portal and Java App Server supported/tested versions

Two questions:
1) The Install Guide for WSRP Portlet Consumer mentions supporting Portal version 4.5, 4.5 WS and 5.0. If running portal 4.5 SP1 as opposed to 4.5 SP2, would we still be able to use the consumer or are there necessary components added in SP2?
2) IBM WebSphere 4.05 is mentioned as a supported Java App Server. Are there any plans for supporting WebSphere 5.0? If so, do you have a rough timeframe?
Thanks, Jon

Oracle BEA WLP 10g3 or 10.2

I'm trying to figure out which version of WLP is best suited for our client. From the product documentation what I could get is that nothing much has changed between 10.2 and 10g3.
1. Is the upgrade process any easier in 10.3 than 10.2 or are the upgrade scripts essentially the same?
2. Do you know of any major defects that appear in 10.3 that did not appear in 10.2?
3. Are there any major defects that exist in 10.2 that are fixed in 10.3?
Also is it possible to develop using Weblogic Wokshop 10g3 and deploy on 10.2 portal/application server?
Chris -
The main differences between WLP 10.2 and 10g3 (a.k.a. 10.3) are that 10.3 uses WLS 10g3 and JDK6 and has the Oracle branding; 10.2 uses WLS 10.0 and JDK5 and has the old BEA branding. WLS 10g3 has a number of features over 10.0, as does JDK6 over JDK5.
To your other questions:
1. The 10g3 upgrade process is the same.
2. The release notes lists the known limitations: [].
3. The release notes also lists the limitations fixed: [] (not too many listed, although I remember fixing more than one bug).
Lastly, it is not supported to develop with WLP in Workshop 10g3 and deploy on a 10.2 server. It is possible to develop in 10.2 and upgrade your projects to 10g3 by opening them in Workshop 10g3 ([]).
Thanks Greg

Add WLS 9.2 runtime to Workshop

Hi there,
how can I add the WLS92 server under "servers" in Workshop 10 (or 10.3)
As I have to develop for WLS92 is it better to use the Workshop that comes with 92?
Workshop 10 (or 10.3) does come up with WLS 9.2 support. Right click in the Servers View, New \ Server, select WebLogic Server 9.2 under BEA Systems Inc category. 
Well, no. At least I do not see it.
When I go to servers, new server, then I have the choice of WLS10 under BEA Systems and Apache 3.2 to Apache 5.5
I have WLS9.2 installed under different BEA_HOME, might this be the difference?
Also I am running Workshop Version: 10.0.1 Build id: 1005184 under Vista.
Ok, now I see, I tried them all:
Workshop of WLS 10.0 no support for WLS9.x
Workshop of WLS 10.1 no support for WLS9.x
Workshop of WLS 10.3 supports WLS9.x
Workspace Studio of ALSB3 supports WLS9.x
Eclipse pack with Eclipse 3.4 ganymed supports WLS9 but no support for WLS web services (IMHO)
So is there any way to point the 10.1 workshop to WLS9? Or just not supported?
I would prefer not to use 10.3 as I need it for web service programming with a group of developers and I like to avoid having all
the JAX-WS stuff in the menues that comes with 10.3g ...
Edited by: Barossa on Dec 31, 2008 10:18 AM
Edited by: Barossa on Dec 31, 2008 10:19 AM 
Workshop of WLS 10.0 no support for WLS9.x
Workshop of WLS 10.1 no support for WLS9.x
Workshop of WLS 10.3 supports WLS9.x
So is there any way to point the 10.1 workshop to WLS9? Or just not supported?The support for multiple versions of WLS was added in Workshop 10.2 (which shipped with Portal), if I remember correctly. Earlier versions of Workshop only supported the version of WLS that they shipped with.
Eclipse pack with Eclipse 3.4 ganymed supports WLS9 but no support for WLS web services (IMHO)That is correct. Eclipse has support for Axis-based web services. Support for WLS webservices will be added to OEPE in the next version that will be released in the first quarter of 2009.

JDK for WLS 9.2 MP4

Currently I am using WLS 9.2 MP4 together with JDK 1.5.0_22 (64bit).
I heard that there is 1.5.0_30 and there is currently a bug in 1.5.0_22.
Based on the link below, it stated 1.5.0_22+.
Anyone using the higher versions of 1.5.0_22 ?
Please let me know, thank you.